Unable to Migrate Some VMs – “Invalid State”

Issue

When attempting to migrate your virtualized recovery server, the process fails with the message:

Error:
Unable to migrate some VMs. Cannot migrate VM SERVERNAME-Recovered because it is in an invalid state.

In the Veeam logs, the following errors are observed:

Error Failed to publish SERVERNAME-Recovered Error: S3 error: not entitled 
Code: AccessDenied 
Agent failed to process method {Cloud.AcquireLock}. 

S3 error: not entitled 
Code: AccessDenied 
Agent failed to process method {Cloud.AcquireLock}. 

Cause

Veeam does not support read only keys for your repository.

Resolution

  1. Delete the Backup Repository in Cloud IBR.
  2. Re-add the repository with the read-write key. (Read directions below for your vendor)
  3. Add the Backup Repository back to Cloud IBR and run a recovery.

At Wasabi and any other Object Storage that utilizes IAM policies:

  • You can either edit your existing policy and change it to read-write by changing:
    • Action”: [
    • “s3:List“,
    • “s3:Get
  • to:
    • “Action”: [
    • “s3:*”
  • Or you can delete the existing policy and create a new one with the above change, applying it to the same programmatic user you created.

At BackBlaze:

  • Create a brand new key.
  • Follow the directions in the Cloud IBR portal to create a new key but choose “Read and Write” for “Type of Access” when creating the key in the BackBlaze portal.

All other Vendors:

  • If you are unsure how to create a Read-Write key for your vendor, please check their website for directions.